Milners Offroad - L200 Forum sponsor L200 Forum   KS International - L200 Forum sponsor
Welcome, Guest. Please login or register.
21 September, 2017, 02:18:13 AM

Login with username, password and session length
160025 Posts in 18167 Topics by 11246 Members
www.L200.org.uk
Can any L200 Owners Club member who moves house or changes their Email address make sure they let us know - so we can keep our records up-to-date
Home L200 Forum L200 Forum & Club Info Buy Owners Club Merchandise at the L200 Forum L200 Forum Gallery L200 Forum Information page Login Register L200 Forum Links Page L200 Forum email
Looking to join the Mitsubishi L200 Owners Club ? - Joining info here - - - - - - - Want to help our charities ? - Shop at Amazon.co.uk through this link
4x4 Accessories & Tyres - L200  Forum sponsor L200 Owners Club Forum - Facebook Page A-Plan L200 insurance - L200 Forum sponsor
+  L200 Owners Club
|-+  The Forum
| |-+  Public/Initial Posting Area.
| | |-+  Rev counter stopped working and won't run, cam sensor?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Rev counter stopped working and won't run, cam sensor?  (Read 8160 times)
ajmoore1
Owners Club member
**
Offline Offline

Posts: 78


« on: 15 March, 2014, 21:06:30 PM »

Hi.

Truck had been running well till tonight.

On my way home the truck lost seemed to die then start again, rev counter flicked back and forth, truck seemed to loose power so pulled over. Noticed the eml light was on but the engine was still running. Turned it off for a quick road side inspection but couldn't see anything obvious. Checked fuel filter but that seems ok. Tried to start but fires up then dies. If you keep turning the key as it dies it sort of runs and accelerates but as soon as the key is released she stops. Managed to get my brother to tow me home.

When we got it back i though I would give it another try and it started and accelerated but the rev counter didn't move. Turned it off and now it just fires up but won't run again!!

Any ideas what it may be. Any suggestion much appreciated.

Thanks

Jon

« Last Edit: 16 March, 2014, 08:17:49 AM by ajmoore1 » Logged

53 plate 4work. Only mod so far egr removed.
mikeinatruck
2003 Oriental Burgundy/Silver
Regional Reps
****
Offline Offline

Gender: Male
Posts: 2545

Piston broke... aren't we all?


WWW
« Reply #1 on: 17 March, 2014, 14:13:37 PM »

Assuming you have a classic, have a look in the tech section it will tell you how to read your fault codes. Once you have done that it will make diagnosis easier.
Logged

2003 Oriental Burgundy/silver
265/75 r16 Tyres. Ironman shocks, TBR torsion bars & +50mm rear springs.
ARB winch bumper
Roof console.
Carryboy canopy

Now with added difflock!

 love it as much as day one! Smiley
rodeast24
Owners Club member
**
Offline Offline

Gender: Male
Posts: 527


« Reply #2 on: 17 March, 2014, 17:11:07 PM »

At a guess i would look at the crank sensor or multi plug wireing to crank sensor
Logged

Warrior 2004 Silver
Fullbox, decat, egr blanked, powerchip, Mac wheels 285/60/18 coopers.Sport grill, twin headlights. 124K, New engine at 102K.
Landrover 90 and discovery td5, also 1958 series 2.. I do love my landys,
Volvo 850R, nissan 300zx twin turbo, Been ordered by a higher athority no more toys.
ajmoore1
Owners Club member
**
Offline Offline

Posts: 78


« Reply #3 on: 19 March, 2014, 21:54:31 PM »

Hi,

Will the crank shaft sensor affect the rev counter as it is not working or will that be another issue? Truck is a 53 plate classic

Cheers
Logged

53 plate 4work. Only mod so far egr removed.
George04
Owners Club member
**
Offline Offline

Posts: 2


« Reply #4 on: 06 April, 2015, 18:03:48 PM »

Hi AJMoore1,
I have an 04 Classic which has been running well but now has the exact symptoms you described in your first post on this thread
I.E.  Power dies whilst driving but continues to idle with EML on. Will start and rev up when turning key to start position but dies when the key is let go. Rev counter not working.
If you are really brutal with the key (keep it turned to the start position) it will occasionally keep running just as it was when it first exhibited the fault. It then idles with the EML on but little or no throttle response unless the vacuum hose is pulled from the inlet butterfly. In this mode it can be driven home but no power available and no Rev counter.
I think it is the crank sensor or its target (chopper) but my question is what did you find wrong with yours in case I am wrong!
Cheers
George
Logged
ajmoore1
Owners Club member
**
Offline Offline

Posts: 78


« Reply #5 on: 06 April, 2015, 18:37:36 PM »

the bolt holding the crank shaft sensor had come loose on mine and the disc had broken it. Replace trhe sensor and disc and was fine after. Got the sensor off ebay.

cheers
Logged

53 plate 4work. Only mod so far egr removed.
George04
Owners Club member
**
Offline Offline

Posts: 2


« Reply #6 on: 06 April, 2015, 22:28:03 PM »

Hi
Thanks for that, I've started to take it apart, I'll update as I go but  it will be next weekend before I get more time.
Cheers
George
Logged
BlackMitsi

Offline Offline

Posts: 19


« Reply #7 on: 30 December, 2015, 19:08:24 PM »

George04- I have very similar symptoms. Any joy with the crank shaft sensor?
Logged
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3079


« Reply #8 on: 30 December, 2015, 19:33:29 PM »

rev counter comes from the sensor on the fuel pump I do believe
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #9 on: 30 December, 2015, 19:47:44 PM »

rev counter comes from the sensor on the fuel pump I do believe

Correct.
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3079


« Reply #10 on: 30 December, 2015, 20:02:15 PM »

the one that looks like a long nut with 2 wires coming out of it I think?  nickburt?

Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #11 on: 31 December, 2015, 09:56:39 AM »

the one that looks like a long nut with 2 wires coming out of it I think?  nickburt?



No, it's a single white wire off the sensor, that becomes a white/red after a connector block
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #12 on: 31 December, 2015, 11:00:09 AM »

the one that looks like a long nut with 2 wires coming out of it I think?  nickburt?



No, it's a single white wire off the sensor, that becomes a white/red after a connector block

Apologies, that's wrong!!  But correct according to the wiring diagram I looked at this morning.

Back later with the right answer!!
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3079


« Reply #13 on: 31 December, 2015, 12:56:50 PM »

i think it becomes 3 wires dont it after the conector block
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3079


« Reply #14 on: 31 December, 2015, 13:03:02 PM »

yeh thts what my diagram says too nick  i need to take my sensor out and check it
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #15 on: 31 December, 2015, 17:01:03 PM »

i think it becomes 3 wires dont it after the conector block

Yes, two wires, black and yellow, become 3 at the connector, black, yellow and green.
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3079


« Reply #16 on: 31 December, 2015, 17:37:01 PM »

have you ever taken that sensor out of the pump NB
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #17 on: 01 January, 2016, 10:13:42 AM »

have you ever taken that sensor out of the pump NB

Nope.   Undecided  Might try one just for the hell of it !!
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3079


« Reply #18 on: 01 January, 2016, 12:23:04 PM »

I suppose u have a spare FP then, let me know how u get on I want to take a look at mine but reluctant as I need the truck for work ATM
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #19 on: 01 January, 2016, 18:34:17 PM »

I suppose u have a spare FP then, let me know how u get on I want to take a look at mine but reluctant as I need the truck for work ATM

Got a couple pumps lying around  Cool  Will have a look tomorrow.
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3079


« Reply #20 on: 01 January, 2016, 19:22:19 PM »

cool be nice to know what that sensor consists of before i remove it
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.1 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!