Milners Offroad - L200 Forum sponsor L200 Forum
Welcome, Guest. Please login or register.
19 August, 2017, 04:28:13 AM

Login with username, password and session length
159887 Posts in 18135 Topics by 11197 Members
www.L200.org.uk
L200 Owners Club Members, please make sure we know your Forum/User name - This will allow us to grant you full access to  this forum
Home L200 Forum L200 Forum & Club Info Buy Owners Club Merchandise at the L200 Forum L200 Forum Gallery L200 Forum Information page Login Register L200 Forum Links Page L200 Forum email
Looking to join the Mitsubishi L200 Owners Club ? - Joining info here - - - - - - - Want to help our charities ? - Shop at Amazon.co.uk through this link
4x4 Accessories & Tyres - L200  Forum sponsor L200 Owners Club Forum - Facebook Page A-Plan L200 insurance - L200 Forum sponsor
+  L200 Owners Club
|-+  The Forum
| |-+  Public/Initial Posting Area.
| | |-+  Engine will not run!!
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] Go Down Print
Author Topic: Engine will not run!!  (Read 10186 times)
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3065


« Reply #40 on: 12 December, 2015, 10:18:02 AM »

buy a genuinee mitsi chip it is just plug and play
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
black8898
Owners Club member
**
Offline Offline

Posts: 24


« Reply #41 on: 12 December, 2015, 10:19:40 AM »

Ok, do I get this from a Mitsi main dealer or from where?
Logged
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3065


« Reply #42 on: 12 December, 2015, 10:29:22 AM »

u can or second hand on ebay or from a breakers
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
black8898
Owners Club member
**
Offline Offline

Posts: 24


« Reply #43 on: 12 December, 2015, 10:36:18 AM »

Thanks for all your info very much appreciated, just one last thing is my vehicle a 100 BHP or 115 BHP? gather that as it doen not have a power upgrade alreday that it will not be 134 BHP.
Logged
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #44 on: 12 December, 2015, 19:12:26 PM »

Probably 115.
I've run a Tunit for years.  Been fine.
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
black8898
Owners Club member
**
Offline Offline

Posts: 24


« Reply #45 on: 12 December, 2015, 20:31:34 PM »

Thanks for your info and yes mine is a 115 Bhp and have been thinking about a Tunit upgrade so might well be going that was and it appears to be at a sensible price at the moment, should work fine if i can get the truck up and running again.

Parts will be here on Monday so should hopefully weather permitting get all the belts and crank sensor all fitted and then keeping my fingers crossed that it will run again although might be just wishful thinking as the timing all appeared to be spot on.
Logged
black8898
Owners Club member
**
Offline Offline

Posts: 24


« Reply #46 on: 26 December, 2015, 13:34:52 PM »

Just to let you all know that the problem with the truck not running was down to the ECU which had blown the circuit track in 3 places, 2 diodes had blown and also a thing called a Zener, I had the ECU repaired by a chap who lives and works on the Isle of Wight and he tested and repaired the ECU and turned it around in 3 days for me which for me was a result, total cost including testing and post etc. was 220 which I was more than happy with as others quoted me what I call telephone number prices, whether this was a good price or not I do not know but as I say I am happy with it and now have finally got the wife off my case.

Not sure what caused the ECU to blow as I have checked just about everything I can and have found no faults etc. anywhere so just keeping my fingers crossed that this does not happen again.

Thanks to everyone who helped me out your help was much appreciated.
 
Logged
nickburt
European Wanderer
Global Moderator & Charity Fundraiser
*****
Offline Offline

Gender: Male
Posts: 14259

Where will the Pheonix take us next?


« Reply #47 on: 26 December, 2015, 13:38:02 PM »

Glad it's sorted.
Logged

Black 2004 Warrior. Gallery

Entry No ?? in the 2017 Macmillan 4x4 UK Challenge
To sponsor Team L200: Donate to Macmillan TBA
123hotchef
Owners Club member
**
Offline Offline

Gender: Male
Posts: 3065


« Reply #48 on: 26 December, 2015, 20:50:31 PM »

result mate,  my ecu had the same problem got it fixed for half that though doh!

been know to be caused by jump starting too
Logged

2005 4 Life
Blue over Silver Double Cab
K&N Apollo EGR removed S/S De-Cat Armadillo Roller Shutter Boost gauge Wax-oiled and under-sealed Interior blue LED's Roll bars
2 Led spots 2 search lights 4 work lights with red angle eyes 7" screen for trailer cams Stereo with flip down screen

To go on
Stainless steel exhaust
black8898
Owners Club member
**
Offline Offline

Posts: 24


« Reply #49 on: 27 December, 2015, 10:49:04 AM »

Never been jump started since I have owned it in fact apart from fitting a battery around 18 months ago and heater plugs well before that I have never had any problems with truck, forgot did replace the exhaust system back in February this year, so no idea as to what caused the problem, at least I know that the timing belts etc. are all good now after changing them and tensioners.
Logged
Pages: 1 [2] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.1 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!