Milners Offroad - L200 Forum sponsor L200 Forum   KS International - L200 Forum sponsor
Welcome, Guest. Please login or register.
23 March, 2018, 13:49:39 PM

Login with username, password and session length
160979 Posts in 18391 Topics by 11475 Members
Members of Mitsubishi L200 Owners Club get access to more areas of the forum e.g. Owners Club Discounts, Owners Club Events, Dealerships and Servicing-DIY & Main Dealer, Not Quite Right.., Polls, Insurance, Wanted, For Sale, Accessories, Technical.
Home L200 Forum L200 Forum & Club Info Buy Owners Club Merchandise at the L200 Forum L200 Forum Gallery L200 Forum Information page Login Register L200 Forum Links Page L200 Forum email
Looking to join the Mitsubishi L200 Owners Club ? - Joining info here - - - - - - - Want to help our charities ? - Shop at through this link
L200 Owners Club Forum - Facebook Page A-Plan L200 insurance - L200 Forum sponsor
+  L200 Owners Club
|-+  The Forum
| |-+  Public/Initial Posting Area.
| | |-+  Heater controls not working
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Heater controls not working  (Read 1828 times)

Offline Offline

Posts: 5

« on: 29 December, 2015, 22:16:49 PM »

Help please.  I've lost my heaters and the controls in my 2011 barbarian.  They light up with the lights.  But the rear window demist. The recirculating button and the air con button are not doing any thing.    I've checked the fuse that the book describes as heaters.  Just wondered if there's and thing else I could check or if I'm not check in the correct fuse.  The only thing I have done to it was wire in a LED light bar yesterday.  But it is not wired into the heating circuit in any way.
Owners Club member
Offline Offline

Gender: Male
Posts: 1790

« Reply #1 on: 29 December, 2015, 23:17:07 PM »

 They all work from same fuse, fuse No 16 inside car under drivers bulkhead . its a 7.5 amp fuse, brown in colour. controls the blower and rear window de mist etc.

 Not sure if they changed fuse numbers on later new shapes so just check all the 7.5 amp brown fuses and you will find it.

5/06 new shape warrior from new 60k, leather interior, air con, pegasus canopy, plastic sliding bed,towbar,Avenger A bar, camera,sensors,cruise control and few bits of bling.daily use as car that carries everything. including building supplies and bike trailer.

Offline Offline

Posts: 5

« Reply #2 on: 30 December, 2015, 12:58:19 PM »

Spot on.  Looked this morning and that was the problem.   Thanks a lot. 
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.1 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!