Milners Offroad - L200 Forum sponsor L200 Forum   KS International - L200 Forum sponsor
Welcome, Guest. Please login or register.
18 November, 2017, 23:09:43 PM

Login with username, password and session length
160235 Posts in 18221 Topics by 11312 Members
www.L200.org.uk
L200 Owners Club Members, please make sure we know your Forum/User name - This will allow us to grant you full access to  this forum
Home L200 Forum L200 Forum & Club Info Buy Owners Club Merchandise at the L200 Forum L200 Forum Gallery L200 Forum Information page Login Register L200 Forum Links Page L200 Forum email
Looking to join the Mitsubishi L200 Owners Club ? - Joining info here - - - - - - - Want to help our charities ? - Shop at Amazon.co.uk through this link
4x4 Accessories & Tyres - L200  Forum sponsor L200 Owners Club Forum - Facebook Page A-Plan L200 insurance - L200 Forum sponsor
+  L200 Owners Club
|-+  The Forum
| |-+  Public/Initial Posting Area.
| | |-+  L200 2008 Diamond automatic
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: L200 2008 Diamond automatic  (Read 44 times)
shirehorse

Offline Offline

Posts: 2


« on: 13 November, 2017, 15:32:48 PM »

Hi all my L200 keeps loosing drive while going along especially when cold, the D sign goes from the dash. If I wiggle or hold the shift lever back it will re-appear and drive again. Is this a common fault or an easy fix please cheers, Ian.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.1 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!