MitzyBitz - L200 Forum sponsor
Welcome, Guest. Please login or register.
13 December, 2019, 07:29:21 AM

Login with username, password and session length
156107 Posts in 18224 Topics by 11972 Members
www.L200.org.uk
Membership to this site is FREE.
Please email or PM me to become a free member
Home L200 Forum L200 Forum & Club Info Buy Owners Club Merchandise at the L200 Forum L200 Forum Gallery L200 Forum Information page Login Register L200 Forum Links Page L200 Forum email
Looking to join the Mitsubishi L200 Owners Club ? - Joining info here - - - - - - - Want to help our charities ? - Shop at Amazon.co.uk through this link
L200 Owners Club Forum - Facebook Page A-Plan L200 insurance - L200 Forum sponsor
+  L200 Owners Club
|-+  The Forum
| |-+  Public/Initial Posting Area.
| | |-+  Coolant level issues
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Coolant level issues  (Read 235 times)
thewall
Owners Club member
**
Offline Offline

Gender: Male
Posts: 210


« on: 28 November, 2019, 19:42:45 PM »


I have had an issue with the coolant filling up the header tank and not returning to the rad i had to syphon out the coolant and put back into the rad, i knew when the coolant had filled up the rad when my heater blows hot then cool, i have change the rad cap and the thermostat but this has not solved the problem, took it in for a service today and asked them to flush out the system and have a look to see if anything was a miss, came back checked everything now going down H/G route.

So i have done some research as i thought this head on 2013 was better than a K74 and a few posts on forums saying this model has a faulty rad which causes the H/G to fail, has anybody experienced or heard of this.

Cheers
Logged

2013 WARRIOR   BLACK   52000ML    HARDTOP R/C/L
rodeast24
Owners Club member
**
Offline Offline

Gender: Male
Posts: 567


« Reply #1 on: 28 November, 2019, 20:43:14 PM »

The rads block up, same as k74, had a similar problem on k74 bottle filling and out the overflow, overheating. new rad and tikity boo
Logged

Warrior 2004 Silver
Fullbox, decat, egr blanked, powerchip, Mac wheels 285/60/18 coopers.Sport grill, twin headlights. 124K, New engine at 102K.
Landrover 90 and discovery td5, also 1958 series 2.. I do love my landys,
Volvo 850R, nissan 300zx twin turbo, Been ordered by a higher athority no more toys.
douchecalamondaes
Owners Club member
**
Offline Offline

Gender: Male
Posts: 4442

hertfordshire


« Reply #2 on: 02 December, 2019, 21:58:45 PM »


I have had an issue with the coolant filling up the header tank and not returning to the rad i had to syphon out the coolant and put back into the rad, i knew when the coolant had filled up the rad when my heater blows hot then cool, i have change the rad cap and the thermostat but this has not solved the problem, took it in for a service today and asked them to flush out the system and have a look to see if anything was a miss, came back checked everything now going down H/G route.

So i have done some research as i thought this head on 2013 was better than a K74 and a few posts on forums saying this model has a faulty rad which causes the H/G to fail, has anybody experienced or heard of this.

Cheers


have the rad cap off, when its hot and its full look for any regular bubbling out of the cap,  anything regular is head or EGR cooler,    if its just vapor and water then get a rad n cap  also make sure theres no leak between rad and bottle
Logged

03 4work, Cummins 6BTA 5.9L engine, 40" round things, and all the accompanying hassle involved.
 
No, my rear windows dont go up either Smiley
024life
04warrior
04 4work
thewall
Owners Club member
**
Offline Offline

Gender: Male
Posts: 210


« Reply #3 on: 04 December, 2019, 15:01:54 PM »

 truck is in the shop now, rad ok,pump ok, rad cap ok, thermostat ok now looking at H/G, seen on other forums heater blowing hot and cold a good sign H/G has failed.
Logged

2013 WARRIOR   BLACK   52000ML    HARDTOP R/C/L
douchecalamondaes
Owners Club member
**
Offline Offline

Gender: Male
Posts: 4442

hertfordshire


« Reply #4 on: 04 December, 2019, 18:24:25 PM »

truck is in the shop now, rad ok,pump ok, rad cap ok, thermostat ok now looking at H/G, seen on other forums heater blowing hot and cold a good sign H/G has failed.

bubbles are a good sign,   heater going cold is a sign of water usage or leakage,,  not a conclusive sign, though could be hg
Logged

03 4work, Cummins 6BTA 5.9L engine, 40" round things, and all the accompanying hassle involved.
 
No, my rear windows dont go up either Smiley
024life
04warrior
04 4work
thewall
Owners Club member
**
Offline Offline

Gender: Male
Posts: 210


« Reply #5 on: 05 December, 2019, 13:36:25 PM »

H/G gone in 2 places  lovely !!!
Logged

2013 WARRIOR   BLACK   52000ML    HARDTOP R/C/L
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.1 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!